Malcolm Keeps Crashing in Maya 2017!!

Discuss anything related to the Malcolm Rig here!
Post Reply
samzilla
Posts: 2
Joined: Fri Mar 31, 2017 8:41 pm

Malcolm Keeps Crashing in Maya 2017!!

Post by samzilla » Fri Mar 31, 2017 8:51 pm

Hello, so every time I set a few keyframes up on Malcolm 2.0 and scroll through the time slider, Maya keeps crashing on me every time. I'm not the only one in my class experiencing this huge problem either. Any ideas?? Is it a problem just with 2017 perhaps, or the way Animschool picker is installed?

User avatar
admin
Site Admin
Posts: 457
Joined: Thu Jul 21, 2011 12:51 pm

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by admin » Tue Apr 04, 2017 12:47 pm

We have not seen that with Maya 2017, no.
Can you try it on another character and see if you get similar problems? Then we'll know if it's Malcolm or AnimSchool Picker.

samzilla
Posts: 2
Joined: Fri Mar 31, 2017 8:41 pm

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by samzilla » Fri Apr 07, 2017 8:06 pm

I tried using Malcolm v1.0 instead, and it works just fine. I think it's version 2.0 that's the problem. I've heard it works better on Maya 2016, but I haven't been able to try that out.

Wolf
Posts: 1
Joined: Tue May 23, 2017 7:59 am

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by Wolf » Tue May 23, 2017 8:05 am

I have been having the same problem.
When you rotate the middle joint that controls the body and rotate it while the timeline is still on frame 1, then move the time slider to a different frame the Maya crashes for me. (from t-pose)
If you move the time slider to a different frame first (for example frame 2) and then rotate and edit the same control everything works fine.
So i can still animate, when i start at frame 2 instead of 1. But i would appreciate if it would get fixed.

murxa
Posts: 2
Joined: Sat Dec 01, 2018 2:05 pm

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by murxa » Sat Dec 01, 2018 2:09 pm

Hello

iam also facing the same issue with malcolm rig in maya 2017. After keying for 2-3 times it keeps on getting stuck and ultimately i have to close my maya and restart. I lost my all day just to figure out some way but unfortunately not.
Iam using Malcolm v.2 and it is referenced.

User avatar
admin
Site Admin
Posts: 457
Joined: Thu Jul 21, 2011 12:51 pm

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by admin » Mon Dec 03, 2018 9:54 pm

The last few versions of Maya have introduced a lot of new things that break older rigs. The main one is parallel execution - it sends rig execution to multiple processors. Unfortunately that can cause crashes on some hardware and software configurations, but it's very hard to debug/reproduce.

You can try installing Maya 2018 Update 4.
(Update 4 is available on the Updates tab on autodesk's site)

And/Or, assuming Parallel execution mode is on, try turning on or off GPU Override:
Settings/Preferences>Settings>Animation>Evaluation>GPU Override

Next try: Viewport, Renderer>Viewport 2.0 Options, Turn off Consolidate World.

If that doesn't help, change Settings/Preferences>Settings>Animation>Evaluation Mode to DG instead of Parallel.

murxa
Posts: 2
Joined: Sat Dec 01, 2018 2:05 pm

Re: Malcolm Keeps Crashing in Maya 2017!!

Post by murxa » Mon Dec 17, 2018 1:27 pm

The last few versions of Maya have introduced a lot of new things that break older rigs. The main one is parallel execution - it sends rig execution to multiple processors. Unfortunately that can cause crashes on some hardware and software configurations, but it's very hard to debug/reproduce.

You can try installing Maya 2018 Update 4.
(Update 4 is available on the Updates tab on autodesk's site)

And/Or, assuming Parallel execution mode is on, try turning on or off GPU Override:
Settings/Preferences>Settings>Animation>Evaluation>GPU Override

Next try: Viewport, Renderer>Viewport 2.0 Options, Turn off Consolidate World.

If that doesn't help, change Settings/Preferences>Settings>Animation>Evaluation Mode to DG instead of Parallel.


This really helped, thanks =)

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests