It is currently Thu Jun 29, 2017 3:13 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Malcolm 2.0 batch render
PostPosted: Wed Mar 09, 2016 4:46 am 
Offline

Joined: Wed Mar 09, 2016 12:49 am
Posts: 2
So, whenever I render from the viewport 2.0, everything is fine, but when I batch render, all his facial animation is gone. I've searched the forums but couldn't find anything besides reloading the reference, which I did a gazillion times from different files and didn't help. I also tried the following script:

setAttr "malcolm:headShape.visibleInRefractions" 1;
setAttr "malcolm:headShape.visibleInReflections" 1;
setAttr "malcolm:headShape.primaryVisibility" 1;
setAttr "malcolm:headShape.motionBlur" 1;
setAttr "malcolm:headShape.receiveShadows" 1;
setAttr "malcolm:headShape.castsShadows" 1;

It worked for the older version of Malcolm, but not for the 2.0.

Any suggestions?
Thank you very much


Top
 Profile  
 
PostPosted: Wed Mar 09, 2016 4:33 pm 
Offline
Site Admin
User avatar

Joined: Thu Jul 21, 2011 12:51 pm
Posts: 410
Regarding that script, of course you'd need to change the namespace to ex: malcolm_v200:


I don't know about the batch script issue. Have you tried importing the reference before rendering?


Top
 Profile  
 
PostPosted: Wed Mar 09, 2016 8:00 pm 
Offline

Joined: Wed Mar 09, 2016 12:49 am
Posts: 2
admin wrote:
Regarding that script, of course you'd need to change the namespace to ex: malcolm_v200:


I don't know about the batch script issue. Have you tried importing the reference before rendering?



I am not sure of what you mean by importing the reference, but I did unload, reload and relinked the reference many times before rendering. I also tried renaming the script for malcolm_v200 but no results either.


Top
 Profile  
 
PostPosted: Fri Mar 11, 2016 1:03 pm 
Offline
Site Admin
User avatar

Joined: Thu Jul 21, 2011 12:51 pm
Posts: 410
In the Reference Editor, select the reference and then use the menu to "Import Objects from Reference" or something like that.
That will break the link between the reference file and sometimes may help problems like this.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group