Malcolm 2.0: Set Keyframe is very slow
Page 1 of 1

Author:  Andreas [ Mon Feb 19, 2018 3:34 pm ]
Post subject:  Malcolm 2.0: Set Keyframe is very slow

Hello People!

I was checking out the Melcolm Rig 2.0 and it is super appealing - really great work.
The only problem I have with it is the amount of time it takes to set a keyframe - especially the first one. I have to say: I am working with character sets and during the blocking stage I set a keyframe on every control. By default the rig has 306 controls visible. The first time I set a key takes about 3 minutes - what is way too long in my opinion. The next keys are created much faster in about 4 seconds because Maya has now most of the information stored. So yes, it is faster, but still slow. I tested it today in Maya 2018, Maya 2017 and on my Laptop. On all devices I noticed the same problem. I did a last test at work on my machine at work which is optimized for Real-Time Visualizations. It has a CPU with about 46 Cores, one Quadro 6500K, SSD's and so on and even there it took about 12 seconds for the first keyframe. Therefore I do not think it is hardware related and something else is causing the problem. Is this problem already known or are there any solutions? :D

Thank you so much for taking your time guys and have a great day!


Author:  admin [ Fri Feb 23, 2018 8:27 pm ]
Post subject:  Re: Malcolm 2.0: Set Keyframe is very slow

That doesn't sound right at all.
I just tried it and was able to set the first keyframe on the controls from the All button - it took less than 2 seconds.
We do have quite a lot of people using it and there are sometimes slowdowns but not like that.

You could try using the Most group or create your own button with the controls you want.

You could try importing the reference.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group