It is currently Sun Jan 20, 2019 1:15 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Fk2Ik error
PostPosted: Wed Apr 24, 2013 5:41 am 
Offline

Joined: Wed Apr 24, 2013 5:22 am
Posts: 3
Hi,

I've installed the AnimSchoolPicker and have been testing it on Malcolm referenced into my scene (namespace: malcolm).
I noticed that the Fk2Ik switch gave me an error message: "No object matches name: malcolm:fkElbowMatchRt"
As a result, the ArmPoleVector isn't matched up to the FK position, and the rest of the script isn't carried out, which means that the "Ik" attribute in the ArmIk controller isn't set to 1.

I don't know if this is a general problem, or if it's somehow only happening for me. Anyway, I did a search in the .ma text document, and couldn't find anything named "Elbow" or "Match" (except for HandMatch), so it seems like this element is completely missing from the rig. Maybe it's there but has a completely different name?

I came up with a fix that seems to work, but if this is indeed an error that is happening not only for me, it would be great if you could address it.

For anyone interested, my fix is as follows:
1) Create a locator and snap it to the position of the ArmPoleVector. Freeze transformations.
2) Rename locator to namespace:fkElbowMatchRt/Lf
3) Parent constrain the locator to the FK elbow controller (ctlArmLoRt/Lf)
3) In picker window, right click on Fk2Ik button -> Edit Command Button...
4) In the section concerning the ElbowMatch and ArmPoleVector, change "move -a -ws ..." to "move -a -os ..." and hit OK

I haven't tested it extensively yet, but it seems to work nicely so far.


Top
 Profile  
 
 Post subject: Re: Fk2Ik error
PostPosted: Wed Apr 24, 2013 9:27 am 
Offline
Site Admin
User avatar

Joined: Thu Jul 21, 2011 12:51 pm
Posts: 448
Or you can download Malcolm v. 1.09:
http://www.animschool.com/DownloadOffer.aspx
Malcolm v1.09 for Maya 2009

Yes, the new AnimSchool Picker is expecting a slightly updated version or Malcolm.


Top
 Profile  
 
 Post subject: Re: Fk2Ik error
PostPosted: Wed Apr 24, 2013 11:05 am 
Offline

Joined: Wed Apr 24, 2013 5:22 am
Posts: 3
Ahaa. I got the rig from a class mate and just assumed he had downloaded the latest version. My bad.
Thanks for the tip!


Top
 Profile  
 
 Post subject: Re: Fk2Ik error
PostPosted: Wed Apr 24, 2013 12:03 pm 
Offline
Site Admin
User avatar

Joined: Thu Jul 21, 2011 12:51 pm
Posts: 448
Hi. You need to download the rig for yourself so you agree to the Terms of Use. You can't just get it from a classmate. If it's from your school, your school may have made the agreement for the students. They must make the Terms of Use clear to you.

Thanks


Top
 Profile  
 
 Post subject: Re: Fk2Ik error
PostPosted: Wed Apr 24, 2013 12:25 pm 
Offline

Joined: Wed Apr 24, 2013 5:22 am
Posts: 3
I've downloaded it properly now. Sorry about that.
(And the picker does indeed work perfectly with the new version :) )


Top
 Profile  
 
 Post subject: Re: Fk2Ik error
PostPosted: Thu Apr 25, 2013 7:37 am 
Offline
Site Admin
User avatar

Joined: Thu Jul 21, 2011 12:51 pm
Posts: 448
Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group