Page 1 of 1

Maya 2016 version

Posted: Mon Jun 01, 2015 3:07 pm
by admin
Hello! AnimSchool Picker is now available for Maya 2016, PC only. (Mac and Linux Maya 2016 coming soon.)

Re: Maya 2016 version

Posted: Mon Jul 06, 2015 2:07 pm
by Ryan
Cool!
Also if you like, you can use this flat icon instead of the main one:
Image
https://www.dropbox.com/s/mj43es80tswc7 ... 9.png?dl=0

;)

Re: Maya 2016 version

Posted: Tue Sep 29, 2015 7:06 pm
by italic_
Any news on the 2016 linux picker?

Re: Maya 2016 version

Posted: Mon Oct 05, 2015 7:10 pm
by admin
Not yet, but hopefully soon.

Re: Maya 2016 version

Posted: Thu Oct 22, 2015 9:35 pm
by draykin
Hi, I"m trying to setup the griffon rig in 2016, but I can't change the namespace.

Re: Maya 2016 version

Posted: Sat Oct 24, 2015 11:12 pm
by italic_
draykin wrote:Hi, I"m trying to setup the griffon rig in 2016, but I can't change the namespace.
That's because your namespaces are so long they are forcing the dropdown menus out of the window. I don't know if the plugin allows you to change window size on Windows (it looks like you're on Windows), but on linux you can expand the frame beyond the screen dimensions, thus exposing the menus to the cursor. You can change the namespace once you see the dropdown menus. I had this problem on a rig before, but all I had to do was maximize the window.

Re: Maya 2016 version

Posted: Wed Oct 28, 2015 5:24 pm
by admin
Hi. Use Picker>Change Namespace

Does that help?
najatuw4646 wrote:but I can't change the namespace.
gclub casino

Re: Maya 2016 version

Posted: Fri Dec 04, 2015 1:10 pm
by admin
AnimSchool Picker is now available for Maya 2016 on Linux!

http://www.animschool.com/DownloadOffer.aspx
italic_ wrote:Any news on the 2016 linux picker?

Re: Maya 2016 version

Posted: Mon Feb 08, 2016 3:49 pm
by Isabel
Hi,

I must be dumb, but how do I install the picker for maya 2016 ? Where do I find the correct install file ?
I downloaded the zip file from the site, followed the instructions from the video, but the latest install file here is for 2015_64bits if I'm not mistaking. I still copied all of that to my 2016 script folder, but when I try the line
loadPlugin -qt "C:/Users/...../AnimSchoolPicker.mll" ;
AnimSchoolPicker ();

Maya answers :
//Error line 1: Plug-in, "AnimSchoolPicker" was compiled against too old a version of the Maya API and is thus incompatible with the current Maya version.

Obviously, I'm not using the correct plugin file. But where is it ? What do I miss ?

Many thanks in advance for helping,

Isabel

Re: Maya 2016 version

Posted: Mon Feb 08, 2016 4:43 pm
by Isabel
Sorry, never mind, reloaded the zip file, found the 2016 folder this time, worked like a charm.
Cheers,
Isabel

Re: Maya 2016 version

Posted: Wed Feb 10, 2016 1:19 am
by admin
Ok great!

Re: Maya 2016 version

Posted: Wed Feb 10, 2016 8:54 pm
by italic_
Thanks! I've been using for some time now and not had any problems with it.

Re: Maya 2016 version

Posted: Sun Apr 24, 2016 7:06 pm
by italic_
I noticed the picker has a button to toggle docking in the channel box/layer editor, but it isn't allowed to dock anywhere else. I used to be able to dock it with a window command and put it on the left side, but that functionality seems to be limited now. Is it possible to allow the window to dock to any region we want? In addition, I believe on Windows the picker is a separate window as a child of the main Maya window, but the Linux picker does not show up when querying window UI elements. It has no title bar and I cannot use standard window operations on it (right click, minimize, maximize, etc.). Was this by design or a consequence of being on Linux? This is likely the cause of my earlier problem, since Maya can't query a window that doesn't exist.

Maya 2016 Extension 2

Posted: Sun May 01, 2016 9:13 am
by blc
Is it just me or does the picker not work with the new Maya 2016 Extension 2?
The performance of the Malcolm rig increased a lot, which is great, but sadly the picker now shows the "api too old" message :(
I didn't expect such a total overhaul of their inner system for Ext 2, so that (some) plugins for 2016 don't work anymore...
Thanks!

Re: Maya 2016 Extension 2

Posted: Sat May 07, 2016 11:20 am
by admin
We'll look into this. Thanks!
blc wrote:Is it just me or does the picker not work with the new Maya 2016 Extension 2?
The performance of the Malcolm rig increased a lot, which is great, but sadly the picker now shows the "api too old" message :(
I didn't expect such a total overhaul of their inner system for Ext 2, so that (some) plugins for 2016 don't work anymore...
Thanks!

Re: Maya 2016 version

Posted: Sun May 08, 2016 5:14 pm
by blc
Thanks, admin!

It really seems like plugins need to be recompiled for Maya 2016.5 (= Extension 2).
See here: https://apps.autodesk.com/MAYA/en/Detai ... appLang=en

Would be awesome to see the picker compiled for the new versions :)

Re: Maya 2016 version

Posted: Tue Jun 14, 2016 7:46 pm
by admin
We do not have that yet, no. Noted!
fahr wrote:Hi there! Has there been any news or progress concerning a compiled plugin for 2016.5?

Thanks!

Re: Maya 2016 version

Posted: Wed Oct 11, 2017 7:46 pm
by zadrel
Hey, Is this fix being worked on? This post was over a year ago and still no fix??

I would really appreciate having the picker available to use in 2016.5 (Linunx CentO7)
admin wrote:We do not have that yet, no. Noted!
fahr wrote:Hi there! Has there been any news or progress concerning a compiled plugin for 2016.5?

Thanks!

Re: Maya 2016 version

Posted: Mon Oct 16, 2017 2:41 pm
by admin
We have posted a version of AnimSchool Picker for Linux Maya 2017 and 2018. Please let us know if you have any issues!

Re: Maya 2016 version

Posted: Wed Oct 18, 2017 8:48 pm
by zadrel
admin wrote:We have posted a version of AnimSchool Picker for Linux Maya 2017 and 2018. Please let us know if you have any issues!
Hi, thank you for the reply.

I am using Maya 2016.5 and the picker will not load because it was compiled against an older version of the Maya API.

here is the exact error message I am getting

loadPlugin -qt "/net/home/maya/2016.5/scripts/AnimSchoolPickerLinuxCent/AnimSchoolPicker/maya2016/AnimSchoolPicker.so";
AnimSchoolPicker();
// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against too old a version of the Maya API and is thus incompatible with the current Maya version. (AnimSchoolPicker) //
// Error: line 2: Cannot find procedure "AnimSchoolPicker". //


I tried using the 2017 picker and the 2018 picker instead, but they would not work either.

To solve this issue I think you need to recompile a 2016 version. This would be much appreciated.

Thank you

Re: Maya 2016 version

Posted: Mon Oct 23, 2017 3:06 pm
by admin
We have now released a version for Linux Maya 2016.5. Let us know if you have any problems with it.

zadrel wrote:
admin wrote:We have posted a version of AnimSchool Picker for Linux Maya 2017 and 2018. Please let us know if you have any issues!
Hi, thank you for the reply.

I am using Maya 2016.5 and the picker will not load because it was compiled against an older version of the Maya API.

here is the exact error message I am getting

loadPlugin -qt "/net/home/maya/2016.5/scripts/AnimSchoolPickerLinuxCent/AnimSchoolPicker/maya2016/AnimSchoolPicker.so";
AnimSchoolPicker();
// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against too old a version of the Maya API and is thus incompatible with the current Maya version. (AnimSchoolPicker) //
// Error: line 2: Cannot find procedure "AnimSchoolPicker". //


I tried using the 2017 picker and the 2018 picker instead, but they would not work either.

To solve this issue I think you need to recompile a 2016 version. This would be much appreciated.

Thank you

Re: Maya 2016 version

Posted: Thu Nov 09, 2017 5:48 pm
by zadrel
Hey thanks,

Everything seems to work now

Re: Maya 2016 version

Posted: Fri May 10, 2019 5:07 pm
by mjoern
Hi, everyone! I'm having the same problem everyone seems to have :

"// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (AnimSchoolPicker) //
// Error: line 2: Cannot find procedure "AnimSchoolPicker". // "

So, I tried to do the "enable cliptools" fix that I saw on another thread, but it didn't really work out, apparently..
I am using the Service Pack 6 of Maya 2016.. Had to update because of another problem (I had constant fatal errors it was very annoying)..

I'm going for that instead of 2019 because I'm working for a project that is done on 2016 and I can't seem to be able to send my clients the animation I did on 2019.. it's fine, my clients are friends and students so they're very understanding XD but still; it's making me look a bit bad.. since I'm supposed to be the pro and them, students..

I really don't know what to do? is it a problem with the service pack? I tried with both 2016.5 and 2016 for the picker version..

Re: Maya 2016 version

Posted: Tue May 14, 2019 6:29 pm
by admin
Make sure you restart Maya after installing the Picker version. It should work yes.

Re: Maya 2016 version

Posted: Mon Jul 08, 2019 12:41 pm
by chairmanmeow
I was using the provided version 1.4.11 because I was getting the same API error for the 2016 (also tried the 2016.5 version), but now 1.4.11 seems permanently expired? I'm Using 2016 Ext 1 SP6, is it possible we could get the expiration removed for 1.4.11 since that seemed to be the only version that was working for many of us?

"// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (AnimSchoolPicker) // "

Re: Maya 2016 version

Posted: Mon Jul 08, 2019 6:44 pm
by admin
We are looking into this - thanks for the information. We have confirmed one of Maya's updates seems to no longer work so we are looking at a special compile for this. Stand by!

Re: Maya 2016 version

Posted: Mon Jul 08, 2019 8:28 pm
by admin
Hello! Please try the new compiled file for Maya 2016:
https://www.animschool.com/DownloadOffer.aspx

Re: Maya 2016 version

Posted: Tue Jul 09, 2019 2:42 pm
by tseyuanchao
Hi,

The compiled file still didn't work for me.

Re: Maya 2016 version

Posted: Wed Jul 10, 2019 2:54 pm
by Andriy
I'm trying to install a current version of AnimSchoolPicker on Mac
High Sierra - Maya 2016 SP7
but it gives me an error:

Code: Select all

loadPlugin -qt "/Users/Shared/Autodesk/maya/2016/plug-ins/AnimSchoolPicker.bundle";
AnimSchoolPicker();
// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (AnimSchoolPicker) // 
// Error: line 2: Cannot find procedure "AnimSchoolPicker". //

Re: Maya 2016 version

Posted: Wed Jul 10, 2019 10:33 pm
by admin
We will probably have an update for the Mac 2016 version soon. It works currently on the non-Service Pack versions of Maya 2016.

Re: Maya 2016 version

Posted: Mon Jul 29, 2019 2:21 pm
by etekinalp
Hello AnimSchool Picker team,

I was wondering if there is any update on the maya2016 SP6 compiled version for PC.
We are currently working and depending on that tool. The current 1.4.11 version has been expired and
after downloading the latest 2.0 version for maya 2016 SP6 we had loading issues since the plugin has been only
compiled for non SP mayas.

I would greatly appreciate if there is a release date or even a version available.

Many thanks,
Emre

Re: Maya 2016 version

Posted: Wed Aug 07, 2019 11:16 am
by Andriy
You can try
Maya 2016 Extention2 SP3 (Maya 2016.5)
seems to be functional

Re: Maya 2016 version

Posted: Mon Aug 12, 2019 11:49 am
by admin
We have posted a new version of the 2016 AnimSchool Picker. Please try to redownload.

Re: Maya 2016 version

Posted: Wed Aug 14, 2019 10:02 am
by Andriy
The problem still persists on Mac High Sierra - Maya 2016 SP7 :cry:

Code: Select all

loadPlugin -qt "/Users/Shared/Autodesk/maya/2016/plug-ins/AnimSchoolPicker.bundle";
AnimSchoolPicker();
// Error: line 1: Plug-in, "AnimSchoolPicker" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (AnimSchoolPicker) // 
// Error: line 2: Cannot find procedure "AnimSchoolPicker". //